Skip to content Skip to sidebar Skip to footer

MikroTik Bandwidth Management + Web Proxy

mtk
Script MikroTik in Black and White
========================
First you need to determining your network model.
in this case we used subnetmask Class "C"
-----------------------------------
255.255.255.0           = 24 -> 254
255.255.255.128       = 25 -> 128
255.255.255.192       = 26 -> 64
255.255.255.224       = 27 -> 32
255.255.255.240       = 28 -> 16
255.255.255.248       = 29 -> 8
255.255.255.252 = 30 -> 4
255.255.255.254 = 31 -> 2
255.255.255.255 = 32 -> 1
        ------------------------------
Note :  if using WinBox Just copy-paste to terminal/linegroup.. Here we go.....;)
           (ISP line  Up to 1 Mbps)

/interface
set 0 name=public
set 1 name=local

password

system identity set name=newbie

/ip address add address=192.168.1.2/24 netmask=255.255.255.0 interface=public comment="Internet"
/ip address add address=192.168.0.1/28 netmask=255.255.255.240 interface=local comment = "LAN"

/ip route add gateway=192.168.1.1

/ip dns set primary-dns=8.8.8.8 allow-remoterequests=yes
/ip dns set secondary-dns=8.8.4.4 allow-remoterequests=yes


/ip web-proxy
set enabled=yes src-address=0.0.0.0 port=3128 hostname="computersnewbie.blogspot.com" transparent-proxy=yes parent-proxy=0.0.0.0:0 cache-administrator="computersnewbie@groups.facebook.com" max-object-size=8192KiB cache-drive=system max-cache-size=unlimited max-ram-cache-size=unlimited

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128 disabled=no
add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=3128 disabled=no
add chain=dstnat protocol=tcp dst-port=8000 action=redirect to-ports=3128
add chain=scrnat out-interface=public action=masquerade


/ip firewall mangle
add chain=prerouting protocol=icmp action=mark-connection new-connection-mark=icmp-con passthrough=yes comment="" disabled=no
add chain=prerouting protocol=icmp connection-mark=icmp-con action=mark-packet new-packet-mark=icmp-pkt passthrough=no comment="" disabled=no
add chain=prerouting action=mark-connection new-connection-mark=con-up passthrough=yes comment=""
add chain=prerouting action=mark-packet new-packet-mark=all-pkt connection-mark=con-up passthrough=no comment=""
add chain=output content="X-Cache: HIT" action=mark-connection new-connection-mark=proxy-con passthrough=yes comment="" disabled=no
add chain=output connection-mark=proxy-con action=mark-packet new-packet-mark=proxy-pkt passthrough=no comment="" disabled=no
add chain=forward action=mark-connection new-connection-mark=direct-con passthrough=yes comment="" disabled=no
add chain=forward protocol=tcp connection-mark=direct-con action=mark-packet new-packet-mark=all-pkt passthrough=no comment="" disabled=no
add chain=output protocol=tcp connection-mark=direct-con action=mark-packet new-packet-mark=all-pkt passthrough=no comment="" disabled=no


/queue simple
add name="proxy-HIT" dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxy-pkt direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no
add name="Ping-queue" dst-address=0.0.0.0/0 interface=all parent=none packet-marks=icmp-pkt direction=both priority=2 queue=default-small/default-small limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no
add name="Parent-queue" dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=200000/850000 total-queue=default-small disabled=no

/queue simple
add name="Billing" target-addresses=192.168.0.2 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="1" target-addresses=192.168.0.3 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="2" target-addresses=192.168.0.4 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="3" target-addresses=192.168.0.5 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="4" target-addresses=192.168.0.6 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="5" target-addresses=192.168.0.7 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="6" target-addresses=192.168.0.8 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="7" target-addresses=192.168.0.9 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="8" target-addresses=192.168.0.10 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="9" target-addresses=192.168.0.11 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no
add name="10" target-addresses=192.168.0.12 dst-address=0.0.0.0/0 interface=all parent=Parent-queue packet-marks=all-pkt direction=both priority=3 queue=default-small/default-small limit-at=20000/85000 max-limit=32000/100000 total-queue=default-small disabled=no


38 comments for "MikroTik Bandwidth Management + Web Proxy"

  1. Thank's for sharing, itu untuk queue nya yang di limit apaan bos? thx

    ReplyDelete
  2. target-addresses=192.168.0.2-12....harusnya cuma packet public,tapi dalam kenyataannya yg proxy HIT juga ikut kelimit...ada solusi bro...xixiixi :)

    ReplyDelete
  3. target for proxy office ?
    I ask ......


    Thank's

    ReplyDelete
  4. Interesting information I haven’t been through such information in a long time.
    Unblock Facebook

    ReplyDelete
  5. This blog post is really great; the standard stuff of the post is genuinely amazing. Facebook Fans kaufen

    ReplyDelete
  6. I’m sure you will provide the more awesome blogs like these blogs that I’ve enjoyed a lot. manassas web design

    ReplyDelete
  7. The complete blogs are really inconceivable and definitely everyone will share this information. social media marketing virginia

    ReplyDelete
  8. The vital information in this blogs has allured me. web development Singapore

    ReplyDelete
  9. I think I have really come on the right place for getting the perfect info. genesis theme framework

    ReplyDelete
  10. Your site is very informative and your articles are wonderful. Niche Marketing

    ReplyDelete
  11. The Info in the blog is out of this world, I so want to read more. comment pirater un compte facebook

    ReplyDelete
  12. Explanation well dear brother thank
    http://www.webfilter-proxy.tk

    ReplyDelete

  13. World-wide-web proxies differ lots with functions and efficiency. The best web proxies offer you SSL stability, which in turn encrypts communications relating to the end user as well as the proxy. The perfect unwanted effect of SSL is actually to be able to get around censorship restrictions with international locations which in turn reduce access to internet websites. World-wide-web proxies additionally find the money for a few additional possibilities that happen to be distinctive for you to this proxy, such as User Realtor covering up, dessert administration, and advert elimination.

    faceb11k

    casslporxy

    sslproxy1

    007z


    ReplyDelete
  14. You guys present there are performing an excellent job. social media infographics

    ReplyDelete
  15. Quality stuff may be the key to invite the users to visit begin to see the blog site, that’s what this site provides. infographic

    ReplyDelete
  16. Free Proxy usa unblocked Youtube, Facebook, Twitter And For Change Your ip Please entre here Free Proxy USA

    ReplyDelete
  17. Free Proxy usa unblocked Youtube, Facebook, Twitter And For Change Your ip Please entre here Free Proxy USA

    ReplyDelete
  18. Your work is totally appreciative and informative. Magnetic Marketing Dan Kennedy

    ReplyDelete
  19. thank you very much i hope that work on my site please help me - See more at

    ssl-4-proxy/

    ReplyDelete
  20. Why Do People Use Web Proxies?
    For most people, web proxies are unknown and usually unexplored territory, however they can be very useful in certain circumstances. Essentially, web proxies are proxy servers which allow you to by-pass filters and blocks which may prevent you from visiting certain websites. Many schools and workplaces have such strong filters in place that people who use their computers cannot even access their hotmail account, let alone social networking sites like MySpace or FaceBook. Furthermore, most people are unaware that governments can block their citizens from visiting certain websites. China, for example, has significant blocks on what its citizens can view over the internet. We should also not assume that Western Countries don't have blocks of their own.

    A sign that a website is being blocked to your IP address is that the page just will not load. You can override such obstructions by taking advantage of a proxy server. Proxy servers work by simply typing in the web address you want to visit into the search box on their web page. You will then visit the website via the proxy's IP address, rather than your own. Chances are, you will now be able to get through to the site.

    If you wish to use a web proxy all the time, rather than just in certain circumstances, you can configure your computer to access the internet via a particular web proxy. This can give you added security if you are concerned that your internet habits could be monitored to use against you in some way. Unfortunately, if the web proxy you choose has been set up by criminals to monitor passwords and to obtain personal financial information you can be in real trouble. It is therefore essential that you take time to research safe and reputable proxy servers.

    Students at schools and universities can be hamstrung by overly tight controls on searches because software protections can cause some terms to be excluded if they have an alternate, negative meaning. Bypassing the security system and accessing a search engine via a proxy server can provide a far broader range of search results to assist with school assignments.

    Of course, we would be naïve to think that school students would only want to bypass their school's computer security for study purposes. Most probably want to talk to their friends on their favorite social networking sites, check their emails or play computer games. These desires will also drive workers to use proxy servers at work.

    There other significant benefits of using a web proxy. Your IP address is hidden which means you cannot be tracked on the internet by marketing companies, spy software, or criminals looking to steal your personal information.

    It is important, however, to understand that you can still be traced via a proxy server, so while you may choose for convenience to bypass controls to view certain websites, make sure that you are not acting illegally. There are real benefits to proxy servers in controlled environments as they can give you the freedom to move as you wish around the internet. However, understand the laws of your country and international laws and act responsibly with proxy servers. They are not a way to cheat law enforcement authorities as log records of proxy servers can be obtained.

    http://www.jobmejlet.com/
    http://www.web-4proxy.com/
    http://www.ssl-4-proxy.com/
    http://www.ooproxy.com/
    http://www.insurance-to-insurance.com/

    ReplyDelete
  21. Your nice work is very attractive and impressive.
    Torrentz UK proxy

    ReplyDelete
  22. This blog is absolutely useful; I love the piece of informative writing. SEO Conference

    ReplyDelete
  23. Very great post. I simply stumbled upon your blog and wanted to say that I have really enjoyed browsing your weblog posts. After all I’ll be subscribing on your feed and I am hoping you write again very soon!

    ReplyDelete
  24. sir is this useful in computer shop?i mean, does this script seperates the online gaming & browsing?

    ReplyDelete
  25. Wonderful blog.. Thanks for sharing information. its very helpful to me..

    goldenslot slot games
    gclub casino
    gclub


    ReplyDelete
  26. Great article, Thanks for your great information, the content is quiet interesting. I will be waiting for your next post.

    ReplyDelete
  27. We're simply a mobilizing service, not a "content scraping proxy". We certainly don't place ads around anyone's content either. http://www.privateproxiesreview.com/proxy-to-bypass-websites/

    ReplyDelete